$re = '/QUILLIVANT.+?(?=QUILLIVANT|$)/i';
$str = 'blahblahblah Quillivant 40MG derp derp derp Quillivant 60MG/5ML Syrup durka durka durka';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);