#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(\w+)\r?\n\s*#\([\s\S]*?\)\s*\).*\r?\n\s*(\w+)"
Local $sString = " block1" & @CRLF & _
" #(/*AUTOINSTPARAM*/" & @CRLF & _
" // Parameters" & @CRLF & _
" .THREE (3), // comment" & @CRLF & _
" .TWO (2), // comment" & @CRLF & _
" .ONE (1)) // comment" & @CRLF & _
" inst1" & @CRLF & _
" (/*AUTOINST*/" & @CRLF & _
" // extra" & @CRLF & _
" // output" & @CRLF & _
"" & @CRLF & _
" block2" & @CRLF & _
" #(/*AUTOINSTPARAM*/" & @CRLF & _
" // Parameters" & @CRLF & _
" .THREE (3), // comment" & @CRLF & _
" .TWO (2), // comment" & @CRLF & _
" .ONE (1)) // comment" & @CRLF & _
" inst2" & @CRLF & _
" (/*AUTOINST*/" & @CRLF & _
" // extra" & @CRLF & _
" // output"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")