import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(\\w+)\\r?\\n\\s*#\\([\\s\\S]*?\\)\\s*\\).*\\r?\\n\\s*(\\w+)";
final String string = " block1\n"
+ " #(/*AUTOINSTPARAM*/\n"
+ " // Parameters\n"
+ " .THREE (3), // comment\n"
+ " .TWO (2), // comment\n"
+ " .ONE (1)) // comment\n"
+ " inst1\n"
+ " (/*AUTOINST*/\n"
+ " // extra\n"
+ " // output\n\n"
+ " block2\n"
+ " #(/*AUTOINSTPARAM*/\n"
+ " // Parameters\n"
+ " .THREE (3), // comment\n"
+ " .TWO (2), // comment\n"
+ " .ONE (1)) // comment\n"
+ " inst2\n"
+ " (/*AUTOINST*/\n"
+ " // extra\n"
+ " // output";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}