using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<html(\s+([a-z\-]+)=('|"")([^""'>]*)('|""))*>";
string input = @"<html class=""my-class"" lang=""en"">";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}