#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?'DateTime'(?'Month'[A-Za-z]+)\s+(?'Day'0?[1-9]|[12][0-9]|3[01])\s+(?'Time'[0-9]{2}:[0-9]{2}:[0-9]{2}(\.[0-9]{1,3})?))\W(?'Full_Host'[alnum]|(?:(?'Host_prefix'(?:[A-Za-z])-?)(?'Host'[A-Za-z]+)-*(?'Host_suffix'-{1}[A-Za-z]+)))\W(?'Msg_Sender'(?:\s?\S+:\s)+)?(?'Log_Msg'[[:blank:][:alnum:][:punct:]]+)"
Local $sString = "May 18 11:02:26 example-host-name kernel: Linux version 6.9.0-gentoo-x86_64 (root@example-host-builder) (x86_64-pc-linux-gnu-gcc (Gentoo Hardened 13.2.1_p20240210 p14) 13.2.1 20240210, GNU ld (Gentoo 2.42 p3) 2.42.0) #1 SMP PREEMPT_DYNAMIC Fri May 17 01:42:56 PDT 2024" & @CRLF & _
"May 18 11:02:26 example-host-name kernel: Kernel is locked down from Kernel configuration; see man kernel_lockdown.7" & @CRLF & _
"May 18 11:02:26 example-host-name kernel: Command line: BOOT_IMAGE=(lvm/vg0-gentoo--root--two)/boot/vmlinuz-6.9.0-gentoo-x86_64.signed root=/dev/dm-4" & @CRLF & _
"May 18 11:02:26 example-host-name kernel: x86/split lock detection: #AC: crashing the kernel on kernel split_locks and warning on user-space split_locks" & @CRLF & _
"May 18 11:02:26 example-host-name kernel: BIOS-provided physical RAM map:" & @CRLF & _
"May 18 11:02:26 example-host-name kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009dfff] usable" & @CRLF & _
"May 18 11:02:26 example-host-name kernel: BIOS-e820: [mem 0x000000000009e000-0x000000000009efff] reserved" & @CRLF & _
"May 18 11:02:26 example-host-name kernel: BIOS-e820: [mem 0x000000000009f000-0x000000000009ffff] usable" & @CRLF & _
"May 18 11:02:26 example-host-name kernel: BIOS-e820: [mem 0x00000000000a0000-0x00000000000fffff] reserved" & @CRLF & _
"May 18 11:02:26 example-host-name kernel: BIOS-e820: [mem 0x0000000000100000-0x000000003aae7fff] usable" & @CRLF & _
"May 18 11:02:26 example-host-name kernel: BIOS-e820: [mem 0x000000003aae8000-0x000000004395efff] reserved" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")