import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "O\\s+(?P<O>\\d+\\.\\d+\\.\\d+\\.\\d+.*(?:[\\r\\n]+[^\\S\\r\\n]+.*)?)";
final String string = "Gateway of last resort is not set\n\n"
+ " 10.0.1.0/8 is variably subnetted, 4 subnets, 2 masks\n"
+ "C 10.1.0.0/24 is directly connected, Ethernet1/0\n"
+ "L 10.1.0.1/32 is directly connected, Ethernet0/0\n"
+ "C 10.2.0.0/24 is directly connected, Ethernet0/1\n"
+ "L 19.18.2.1/32 is directly connected, Serial2/1\n"
+ "O 19.18.3.0/20 [110/128] via 19.18.2.2, 00:00:50, Serial1/1\n"
+ " [110/128] via 19.18.1.2, 00:00:50, Serial1/0\n\n"
+ "O 12.18.3.1/20 [110/128] via 19.18.2.2, 00:00:50, Serial1/1\n"
+ " [110/128] via 19.18.1.2, 00:00:50, Serial1/0\n\n"
+ "O 12.18.1.0/20 [110/128] via 19.18.2.2, 00:00:50, Serial0/1\n"
+ " [110/128] via 19.18.1.2, 00:00:50, Serial0/0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}