$re = '/.*\S*\*(?=\s|$)/m';
$str = 'ip*
ip*5p
*ip
this is ip*
give me *ip not here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);