re = /.*\S*\*(?=\s|$)/m
str = 'ip*
ip*5p
*ip
this is ip*
give me *ip not here'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end