#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<my:group1>(.*)<\/my:group1>"
Local $sString = "<?xml version="1.0" encoding="UTF-8"?>" & @CRLF & _
"<?mso-infoPathSolution solutionVersion="1.0.0.182" productVersion="15.0.0" PIVersion="1.0.0.0" href="http://sp01/hp/Therapy/Forms/template.xsn" name="urn:schemas-microsoft-com:office:infopath:Therapy:-myXSD-2013-03-01T10-07-30" ?>" & @CRLF & _
"<?mso-application progid="InfoPath.Document" versionProgid="InfoPath.Document.3"?>" & @CRLF & _
"<my:myFields" & @CRLF & _
" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"" & @CRLF & _
" xmlns:pc="http://schemas.microsoft.com/office/infopath/2007/PartnerControls"" & @CRLF & _
" xmlns:ma="http://schemas.microsoft.com/office/2009/metadata/properties/metaAttributes"" & @CRLF & _
" xmlns:d="http://schemas.microsoft.com/office/infopath/2009/WSSList/dataFields"" & @CRLF & _
" xmlns:q="http://schemas.microsoft.com/office/infopath/2009/WSSList/queryFields"" & @CRLF & _
" xmlns:dfs="http://schemas.microsoft.com/office/infopath/2003/dataFormSolution"" & @CRLF & _
" xmlns:dms="http://schemas.microsoft.com/office/2009/documentManagement/types"" & @CRLF & _
" xmlns:xhtml="http://www.w3.org/1999/xhtml"" & @CRLF & _
" xmlns:my="http://schemas.microsoft.com/office/infopath/2003/myXSD/2013-03-01T10:07:30"" & @CRLF & _
" xmlns:xd="http://schemas.microsoft.com/office/infopath/2003"" & @CRLF & _
" xml:lang="en-us">" & @CRLF & _
" <my:PatientID>1</my:PatientID>" & @CRLF & _
" <my:Name>name</my:Name>" & @CRLF & _
" <my:Age>29.0000000000000</my:Age>" & @CRLF & _
" <my:Gender>gender</my:Gender>" & @CRLF & _
" <my:Date>2015-12-09</my:Date>" & @CRLF & _
" <my:group1>" & @CRLF & _
" <my:group2>" & @CRLF & _
" <my:field1>1</my:field1>" & @CRLF & _
" <my:PName>pname</my:PName>" & @CRLF & _
" <my:PPrice>10000.0000000000</my:PPrice>" & @CRLF & _
" <my:field11 xsi:nil="true"></my:field11>" & @CRLF & _
" </my:group2>" & @CRLF & _
" <my:group2>" & @CRLF & _
" <my:field1>9</my:field1>" & @CRLF & _
" <my:PName>pname" & @CRLF & _
" </my:PName>" & @CRLF & _
" <my:PPrice>10000.0000000000</my:PPrice>" & @CRLF & _
" <my:field11 xsi:nil="true"></my:field11>" & @CRLF & _
" </my:group2>" & @CRLF & _
" </my:group1>" & @CRLF & _
" <my:field4></my:field4>" & @CRLF & _
" <my:field5></my:field5>" & @CRLF & _
" <my:Status>false</my:Status>" & @CRLF & _
" <my:Confirm>false</my:Confirm>" & @CRLF & _
" <my:field6></my:field6>" & @CRLF & _
" <my:field7></my:field7>" & @CRLF & _
" <my:field8></my:field8>" & @CRLF & _
" <my:TPrice>20000</my:TPrice>" & @CRLF & _
" <my:field12></my:field12>" & @CRLF & _
" <my:field13></my:field13>" & @CRLF & _
" <my:insurance>1</my:insurance>" & @CRLF & _
" <my:Partner>partner</my:Partner>" & @CRLF & _
" <my:Doctor>doctor</my:Doctor>" & @CRLF & _
"</my:myFields>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")