import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<my:group1>(.*)<\\/my:group1>";
final String string = "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
+ "<?mso-infoPathSolution solutionVersion=\"1.0.0.182\" productVersion=\"15.0.0\" PIVersion=\"1.0.0.0\" href=\"http://sp01/hp/Therapy/Forms/template.xsn\" name=\"urn:schemas-microsoft-com:office:infopath:Therapy:-myXSD-2013-03-01T10-07-30\" ?>\n"
+ "<?mso-application progid=\"InfoPath.Document\" versionProgid=\"InfoPath.Document.3\"?>\n"
+ "<my:myFields\n"
+ " xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\"\n"
+ " xmlns:pc=\"http://schemas.microsoft.com/office/infopath/2007/PartnerControls\"\n"
+ " xmlns:ma=\"http://schemas.microsoft.com/office/2009/metadata/properties/metaAttributes\"\n"
+ " xmlns:d=\"http://schemas.microsoft.com/office/infopath/2009/WSSList/dataFields\"\n"
+ " xmlns:q=\"http://schemas.microsoft.com/office/infopath/2009/WSSList/queryFields\"\n"
+ " xmlns:dfs=\"http://schemas.microsoft.com/office/infopath/2003/dataFormSolution\"\n"
+ " xmlns:dms=\"http://schemas.microsoft.com/office/2009/documentManagement/types\"\n"
+ " xmlns:xhtml=\"http://www.w3.org/1999/xhtml\"\n"
+ " xmlns:my=\"http://schemas.microsoft.com/office/infopath/2003/myXSD/2013-03-01T10:07:30\"\n"
+ " xmlns:xd=\"http://schemas.microsoft.com/office/infopath/2003\"\n"
+ " xml:lang=\"en-us\">\n"
+ " <my:PatientID>1</my:PatientID>\n"
+ " <my:Name>name</my:Name>\n"
+ " <my:Age>29.0000000000000</my:Age>\n"
+ " <my:Gender>gender</my:Gender>\n"
+ " <my:Date>2015-12-09</my:Date>\n"
+ " <my:group1>\n"
+ " <my:group2>\n"
+ " <my:field1>1</my:field1>\n"
+ " <my:PName>pname</my:PName>\n"
+ " <my:PPrice>10000.0000000000</my:PPrice>\n"
+ " <my:field11 xsi:nil=\"true\"></my:field11>\n"
+ " </my:group2>\n"
+ " <my:group2>\n"
+ " <my:field1>9</my:field1>\n"
+ " <my:PName>pname\n"
+ " </my:PName>\n"
+ " <my:PPrice>10000.0000000000</my:PPrice>\n"
+ " <my:field11 xsi:nil=\"true\"></my:field11>\n"
+ " </my:group2>\n"
+ " </my:group1>\n"
+ " <my:field4></my:field4>\n"
+ " <my:field5></my:field5>\n"
+ " <my:Status>false</my:Status>\n"
+ " <my:Confirm>false</my:Confirm>\n"
+ " <my:field6></my:field6>\n"
+ " <my:field7></my:field7>\n"
+ " <my:field8></my:field8>\n"
+ " <my:TPrice>20000</my:TPrice>\n"
+ " <my:field12></my:field12>\n"
+ " <my:field13></my:field13>\n"
+ " <my:insurance>1</my:insurance>\n"
+ " <my:Partner>partner</my:Partner>\n"
+ " <my:Doctor>doctor</my:Doctor>\n"
+ "</my:myFields>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}