package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<device[^>]*>)`)
var str = `level=<device[195].level>&name=<device[195].name>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}