$re = '/(<device[^>]*>)/';
$str = 'level=<device[195].level>&name=<device[195].name>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);