$re = '/(?:ht|f)tps?\:\/\/[a-zA-Z0-9\-.]+\.[a-zA-Z]{2,3}(\/\S*)?/';
$str = 'http://vacante2016.eu/tr/17599/51743713/c4f5eadf38eb475d39e3cde=ca9201538';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);