re = /(?:ht|f)tps?\:\/\/[a-zA-Z0-9\-.]+\.[a-zA-Z]{2,3}(\/\S*)?/
str = 'http://vacante2016.eu/tr/17599/51743713/c4f5eadf38eb475d39e3cde=ca9201538'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end