$re = '/\d*$/';
$str = 'There maybe misleading numbers in the text. One example is 82683. Look only for the next nothing and the next nothing is 63579';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);