import Foundation
let pattern = #"\d*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"There maybe misleading numbers in the text. One example is 82683. Look only for the next nothing and the next nothing is 63579"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}