using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d)\b";
string substitution = @"0\1";
string input = @"1:6
2:6:3
02:5";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}