$re = '/\b(\d)\b/';
$str = '1:6
2:6:3
02:5';
$subst = "0\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;