using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\/\*+)(\*|\s)*([^]*[\*]*)(\*|\s)*(\*+\/))";
string input = @"/*basic comment*/
console.log('turtle');
/*********************
Fancy liney comment
*********************/
console.log('turtle');
/****long basic comment ****/
console.log('turtle');
/*
*
* Oh look, it's one of these... great.
*
*/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}