re = /((\/\*+)(\*|\s)*([^]*[\*]*)(\*|\s)*(\*+\/))/
str = '/*basic comment*/
console.log(\'turtle\');
/*********************
Fancy liney comment
*********************/
console.log(\'turtle\');
/****long basic comment ****/
console.log(\'turtle\');
/*
*
* Oh look, it\'s one of these... great.
*
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end