$re = '/(?!.+(\bgoogle.com\b))(<a[^>]+href=")(http|https)([^>" ]+)("?[^>]*>)/m';
$str = '1224 <a href="http://www.google.com">google</a> 567
1224 <a href="http://www.g00gle.com">google</a> 567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);