re = /(?!.+(\bgoogle.com\b))(<a[^>]+href=")(http|https)([^>" ]+)("?[^>]*>)/m
str = '1224 <a href="http://www.google.com">google</a> 567
1224 <a href="http://www.g00gle.com">google</a> 567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end