package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bTOP\b *(\d+)`)
var str = `SELECT TOP 100 * FROM DSMS_Log.dbo.LoggingDetail WITH(NOLOCK) ORDER BY LogTime DESC`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}