re = /\bTOP\b *(\d+)/
str = 'SELECT TOP 100 * FROM DSMS_Log.dbo.LoggingDetail WITH(NOLOCK) ORDER BY LogTime DESC'
# Print the match result
str.match(re) do |match|
puts match.to_s
end