import Foundation
let pattern = #"^\s*BEGIN\R\s*.*\R"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
BEGIN
MultiUse = -1 'True
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}