$re = '/^(?:[^L\n]*L){2}[^L\n]*$/m';
$str = 'Should match:
LLAMA
SHELLS
LEVEL
Should not match
LOSER
LEVELLED';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);