re = /^(?:[^L\n]*L){2}[^L\n]*$/m
str = 'Should match:
LLAMA
SHELLS
LEVEL
Should not match
LOSER
LEVELLED'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end