import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ # beginning of string\n"
+ "(?:\n"
+ " . # match a single character\n"
+ " (?=\n"
+ " .*?\n"
+ " # if we already have captured the end of the string\n"
+ " (?(1)\n"
+ " # make sure we do not go past the correct position\n"
+ " (?= .\\1$ )\n"
+ " )\n"
+ " # capture the end of the string +1 character, adding to \\1 every iteration\n"
+ " ( .\\1?$ )\n"
+ " )\n"
+ ")* # repeat\n"
+ "# the middle character follows, capture it\n"
+ "(.)";
final String string = "1\n"
+ "123\n"
+ "12345\n"
+ "1234567\n"
+ "123456789\n"
+ "12345678901\n"
+ "1234567890123\n"
+ "123456789012345\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}