re = /^ # beginning of string
(?:
. # match a single character
(?=
.*?
# if we already have captured the end of the string
(?(1)
# make sure we do not go past the correct position
(?= .\1$ )
)
# capture the end of the string +1 character, adding to \1 every iteration
( .\1?$ )
)
)* # repeat
# the middle character follows, capture it
(.)/xm
str = '1
123
12345
1234567
123456789
12345678901
1234567890123
123456789012345
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end