using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[(]?\d{3}[)]?)?\s*\d{3}(\-|\s)?\d{4}\s*";
string input = @"5065067065";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}