package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[(]?\d{3}[)]?)?\s*\d{3}(\-|\s)?\d{4}\s*`)
var str = `5065067065`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}