$re = '/^.*\K\b\d{4}\b/m';
$str = 'June 1995 – June 2003 (8 years 1 month)
1989 – June 1995 (6 years) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);