re = /^.*\K\b\d{4}\b/m
str = 'June 1995 – June 2003 (8 years 1 month)
1989 – June 1995 (6 years) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end