import re
regex = re.compile(r"^begin.*(?:\n(?!^end).*)*536916223(?:.*\n)*?^end", flags=re.MULTILINE)
test_str = ("begin active link\n"
" export-version : 11\n"
" actlink-order : 2\n"
" wk-conn-type : 1\n"
" schema-name : HelpDesk\n"
" actlink-mask : 1\n"
" actlink-control: 750000002\n"
" enable : 1\n"
" action {\n"
" set-field : 0\\536916222\\101\\4\\1\\1\\\n"
" }\n"
" errhandler-name: \n"
"end\n"
"begin active link\n"
" export-version : 11\n"
" actlink-order : 2\n"
" wk-conn-type : 1\n"
" schema-name : HelpDesk\n"
" actlink-mask : 1\n"
" actlink-control: 610000092\n"
" enable : 1\n"
" permission : 0\n"
" action {\n"
" id : 536916223\n"
" focus : 0\n"
" access-opt : 1\n"
" option : 0\n"
" }\n"
" action {\n"
" set-field : 0\\536916222\\101\\4\\1\\1\\\n"
" }\n"
" errhandler-opt : 0\n"
" errhandler-name: \n"
"end\n"
"begin active link\n"
" actlink-order : 12\n"
" wk-conn-type : 1\n"
" schema-name : HelpDesk\n"
" actlink-mask : 2064\n"
" enable : 1\n"
" permission : 0\n"
" action {\n"
" id : 536916223\n"
" focus : 0\n"
" access-opt : 1\n"
" option : 0\n"
" }\n"
" action {\n"
" set-field : 0\\536916222\\101\\4\\1\\1\\\n"
" }\n"
" errhandler-opt : 0\n"
" errhandler-name: \n"
"end")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")