re = /^begin.*(?:\n(?!^end).*)*536916223(?:.*\n)*?^end/m
str = 'begin active link
export-version : 11
actlink-order : 2
wk-conn-type : 1
schema-name : HelpDesk
actlink-mask : 1
actlink-control: 750000002
enable : 1
action {
set-field : 0\\536916222\\101\\4\\1\\1\\
}
errhandler-name:
end
begin active link
export-version : 11
actlink-order : 2
wk-conn-type : 1
schema-name : HelpDesk
actlink-mask : 1
actlink-control: 610000092
enable : 1
permission : 0
action {
id : 536916223
focus : 0
access-opt : 1
option : 0
}
action {
set-field : 0\\536916222\\101\\4\\1\\1\\
}
errhandler-opt : 0
errhandler-name:
end
begin active link
actlink-order : 12
wk-conn-type : 1
schema-name : HelpDesk
actlink-mask : 2064
enable : 1
permission : 0
action {
id : 536916223
focus : 0
access-opt : 1
option : 0
}
action {
set-field : 0\\536916222\\101\\4\\1\\1\\
}
errhandler-opt : 0
errhandler-name:
end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end