import Foundation
let pattern = #"\b[\dA-F]{8}-[\dA-F]{4}-[\dA-F]{4}-[\dA-F]{4}-[\dA-F]{12}-\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"id=1 name=4a3779ab-56cc-41b5-ac7c-03bbf673439c-53607.jpg count=53607"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}