re = /([^#:]+):([^#]+)/
str = 'SiteId:BLR232#Latitude:12.918444#Longitude:77.5940136#NetworkType:4g#Type:NONE#Type of Complaint:Call Drop#Sample Number:7022979575#Problem Description:agshjs vshsijsb#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end