const regex = /^(2[4-9]|3[0-9]|40)[\s+?]$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(2[4-9]|3[0-9]|40)[\\s+?]$', '')
const str = `1 00001 00001 123 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}