$re = '/^(2[4-9]|3[0-9]|40)[\s+?]$/';
$str = '1 00001 00001 123 ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);