package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(\bips[uü]\b)`)
var str = `lorem ipsüm dolor ipsum dolor`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}