package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bis\s+([^.]*)`)
var str = `Robert is an English actor, model and musician.
He started his film career by playing Cedric Diggory in Harry Potter.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}