$re = '/.*?\(\([\d.,]+\)\)/';
$str = 'some text that can contains anything ((12.1,5.2))another text that can contains anything ((1,8.7)) and so on...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);