re = /.*?\(\([\d.,]+\)\)/
str = 'some text that can contains anything ((12.1,5.2))another text that can contains anything ((1,8.7)) and so on...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end