re = /(^$|(http(s)?:\/\/)([\w-]+\.)+[\w-]+([\w- ;,.\/?%&=]*))/
str = 'http://www.google.com/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end