// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m),".*?","#).unwrap();
let string = "\"Test\",\"test\",\"test1234\",\"\",\"\"
\"Test\",\"test\",\"test1234\",\"url_test.com/test\",\"\"
\"Test\",\"test\",\"test1234\",\"\",\"testing\"
\"Test\",\"test\",\"test12\"34\",\"\",\"\"
\"Test\",\"test\",\"te\\\"st1234\",\"\",\"\"
\"Test\",\"test\",\"test1\"2,34\",\"\",\"\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}