re = /[0-9!"§$%&\/()=?`´*+~'#_:,.;|<>@^°]/m
str = 'rweéw~ed^d_-eÃã â âäöüdfggdg dfgdg%$4324üf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end