#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^,]*),([^,]*),"
Local $sString = "blue,black,red" & @CRLF & _
"blue,black,red,yellow"
Local $sSubst = "\1:\2:"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)