$re = '/((?:\.|\#)fui-arrow-right:before(?:(?:.)*\n)*})/';
$str = '#fui-arrow-right:before {
content: "02c";
йцуйцу
йуйцуйцу
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);