re = /((?:\.|\#)fui-arrow-right:before(?:(?:.)*\n)*})/
str = '#fui-arrow-right:before {
content: "02c";
йцуйцу
йуйцуйцу
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end