$re = '/<img(?:(?!\.gif\b)[^>])+>/';
$str = '<img src="test.jpg">
<img src="test.gif">
<img src="test.png">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);